SCCM 2012: Reporting Services Point does not install

When adding the Reporting Services Role to SCCM 2012, you might run into the following error found in the srsrp.log File and there are no standard Reports displayed in the SCCM Console:

Created folder [ConfigMgr_PR1]. SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Creating data source {5C6358F2-4BB6-4a1b-A16E-8D96795D8602} at ConfigMgr_PR1 SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Invalid class SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Could not retrieve the reporting service name for instance ‘MSSQLSERVER’ SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Invalid class SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Could not stop the reporting service ” SMS_SRS_REPORTING_POINT 9/27/2012 9:18:42 AM 8264 (0x2048)

Next security configuration at [9/27/2012 9:23:15 AM] SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

Root Folder exists SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

Successfully checked that the SRS web service is healthy on server MICROCCM01.microtom.net SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

SRSRP registry key change notification triggered. SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 9/27/2012 9:18:43 AM 8264 (0x2048)

Timed Out… SMS_SRS_REPORTING_POINT 9/27/2012 9:19:43 AM 8264 (0x2048)

This can happen as of missing WMI Attributes.

To resolve it, use mofcomp.exe to register the SQL MOF Files as follows:

Open an elevated command prompt and type

For SQL Server 2010:

mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

For SQL Server 2012:

mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\110\Shared\sqlmgmproviderxpsp2up.mof"

 

When done, wait half an hour or so to let SCCM create it. You might need to restart the Console to see the Reports!

8 responses to SCCM 2012: Reporting Services Point does not install

I had this issue with SQL 2008 R2, and it worked for me.
I may have had this issue because there are some SQL 2012 (dev studio) parts installed on this server.

Thank you so much, this is an obscure issue and was just opening a case with Microsoft regarding it before I found your suggestion. Worked like a charm, 5 minutes later something that I had spent hours trying to fix (and was close to completely rebuilding my SCCM environment over) was working.
Seriously appreciate people who find these issues, resolve them and then post them on-line.

This worked for me in 3 minutes flat. I had tried so many things too numerous to mention here. Like a comment about, I was about ready to restore from backup.

Serious appreciation to this site..and the people involved!!! wow

Many Thanks.. The above method worked for me.. After spending d whole day trying to figure out the issues, finally i resolved using ur command.
U made my Day.

Leave a Reply